2018年7月
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 31        

カテゴリー

  • Android
  • iOS
  • iPad
  • iPhone
  • iPhone Jailbreak関連
  • unlock
  • アメリカでの暮らしについて
  • クルマ・ドライブ・チューニング
  • パソコン・インターネット
  • 携帯・デジカメ
  • 日記・コラム・つぶやき
  • 映画・テレビ
  • 自動車ニュース&コラム
  • 随時更新…気ままな一言

アクセスランキング
無料ブログはココログ

« Purplera1nによるiPhone 3GSのJailbreak その2 | トップページ | Purplera1n for Mac »

2009年7月 6日 (月)

Ultrasn0wによる3G・Wi-Fiシグナルロスト問題

前の日記にも書いているが、3GSでUltrasn0wを使ってSIMフリー化すると、3GとWi-Fiシグナルを一分おきにロストして、そのたびに接続が途絶えてしまう、という問題が出ている。 対策としてはマニュアルでネットワークキャリアを選択する、という方法を書いたが、自分なりにもう少し調べて他の対策が見つかったので報告する。

その前に、これは人によって(というかiPhoneによって)は症状が現れない、ということもあるようだ。 おそらく、Jailbreak後に旧iPhoneの環境を移していたりする場合、その環境によってこの不具合が出たり、出なかったりするのだろう。 もし、あなたがこれからJailbreakとSIMフリー化をしようとしているなら、、iTunesに同期する際には「新規のiPhone」で同期させたほうがいろいろなトラブルが起きなくていいと思う。 特に、3Gから機種変更してそのままの環境を3GSに移したような人は要注意かも知れない。
また、この3Gシグナル・Wi-Fiのロスト不具合は、私の場合本家のAT&TのSIMを入れていても発生してしまう。 こうなるとキャリアを選択するわけにもいかず、困ってしまうのだ。

さて、私のやった対策はこんな感じだ。

SBSettingまたはBossPrefsを使い、3GとEDGE、Wi-Fiをカットする。

その状態でリブート

再起動したら、次にカットした3GとEDGE、Wi-Fiを元にもどす。

これだけで3Gシグナル・Wi-Fiのロスト不具合が解消された。

ひょっとすると、もっと他に良い方法があるかも知れないが、これでとりあえずできたのでよしとしている。 この状態では、完全な解決方法にはなっていないので、再起動をするとまたロストが始まってしまう。 そのうち、iPhoneをまっさらに戻してJailbreakしなおしてみたいが、なかなか普段使っているだけに難しい。 サブマシンの3GにSIMを入れ替えて、そのうちトライしてみよう。

☆ 1日1回、応援のクリックをお願いします!
                  
  ↓ ↓ ↓
  
→  人気ブログランキング ブログパーツ

ソーシャルブックマークに追加:はてなにブックマークはてな  YahooにブックマークYahoo users LivedoorにブックマークLivedoor  del.icio.usにブックマークdel.icio.us  FC2にブックマークFC2  ニフティにブックマークニフティ   その価格OK?-楽天・アマゾン・ヤフオク・価格.COM、比較検索

« Purplera1nによるiPhone 3GSのJailbreak その2 | トップページ | Purplera1n for Mac »

コメント

Dev-Teamのブログでは、ネットワーク設定をリセットと紹介されていました。わたしは、これでWLANを捕捉できるようになりました。参考まで。

早速0.8試してみました。
見事成功です。
Kellyさんのおっしゃるとおり、再起動後1分以内に一度ロストしますが、その後は安定しています。
情報ありがとうございました。

azさん
そうですか。。私は3Gからデータ復元をしているのですが、ロストは止まってるんですよね。
ちなみに本日、ultrasn0wが0.8にバージョンアップしてますが、試されました?
これは、昨日の方法でも、普通にインストールしてみても、私の3GSでは再起動後1分以内に一回だけロストするようなのですが、その後は安定してます。

Kellyさんの方法やってみましたが成功しませんでした。
ultras0undさんの方法を試しましたが再起動し直すとロスト現象が発生します。
また新しいiPhoneとして登録しなおしもやってみましたが、それもダメでした。
何が悪いんでしょうかね?

ultras0undさん
どうも情報ありがとうございます。 Ultrasn0wをインストールする際に、電話回線が繋がっているとまずそうみたいですね。 ちょっと私の方でも検証してみます。

再投稿です。。。
下記を参考にultrasn0wを再インストールしたら、ロスト現象が止まりました。
http://www.ilikemyiphone.com/2009/06/23/unlock-your-iphone-3g-using-ultrasn0w-quick-and-easy-screenshots-incl/

1. ultrasn0wをアンインストール
2. 3Gをオフ、機内モードにして、Wi-Fi接続しリブート
3. cydiaからultrasn0wをインストールしリブート
4. 3Gをオン、機内モードをオフ

これで普通に再起動してもロストしません。まだ、softbankのSIMだけでの確認で、2日後から海外出張なので、他キャリアのSIMでの動作確認はまだなのですが、なんとか動きそうです。

早速試してみました。
でも自分の場合は「3GとEDGE、Wi-Fiをカット」では成功せず、機内モードにした状態でのリブートでロストが止まりました。
再起動をするとロストが始まるのは同じですが。。

コメントを書く

(ウェブ上には掲載しません)

トラックバック

この記事のトラックバックURL:
http://app.cocolog-nifty.com/t/trackback/175652/45554059

この記事へのトラックバック一覧です: Ultrasn0wによる3G・Wi-Fiシグナルロスト問題:

« Purplera1nによるiPhone 3GSのJailbreak その2 | トップページ | Purplera1n for Mac »